ASM ClassReader failed to parse class file - probably due to a new Java class file version that isn't supported yet:




대충 에러 내용이 ASM ClassReader가 버전이 달라서 읽을 수 없다고 하는 내용입니다.


람다를 사용하기 위해 1.8로 변경했는데 Spring의 버전이 낮아서 생긴 에러입니다.


출처 : https://spring.io/blog/2014/03/27/spring-framework-4-0-3-released-with-java-8-support-now-production-ready

+ Recent posts